1

Closed

Typo inside AssertInvocationsWasMade.MatchingExpecationsFor method

description

There is a typo inside the AssertInvocationsWasMade.MatchingExpecationsFor() method. "MatchingExpectationsFor" would be correct or better MatchExpectationsFor or VerifyExpectationsFor().

The class name AssertInvocationsWasMade sound a little bit strange too ;)

AssertInvocationsWereMade or AssertInvocationWasMade?

Thanks for contributing Simple.Mocking. Currently my first choice when it comes to mocking frameworks :)
Closed Nov 30, 2012 at 3:10 PM by mikwal
Type fixed in 1.1.0.3

comments

mikwal wrote Aug 2, 2012 at 8:03 AM

I will change AssertInvocationsWasMade.MatchingExpecationsFor to AssertInvocationsWereMade.MatchingExpectationsFor for the next release.
It should be plural form because you can chain multiple asserts after each other.

Thanks!